Rules

The Bugs forum thread is not just for reporting bugs to the administration. It is intended to solve technical problems encountered in the game. Before creating a topic, you should check to see if there is a topic with the bug that you want to report. In order to report bugs or glitches, you can create a new thread instead of writing in the existing threads. Topics with the title Bug, Glitch will not be considered. Try to put a brief description of your problem in the title of the topic. If the problem described above occurred on another account, be sure to specify the account where it occurred.
Responsible: RedBarmaley  

Poor Design & Change Control, Losses due to poor design and change control

Post  Post #1 
Reputation 11
Group humans Alliance United Nations 64 23 42 Points 3 666 842 Messages 16
The user on whose account the problem was detected:
Magisteria (+ Xerj and Toss accounts)

Coordinates:
Various

Date or time of the incident (according to server time):
15 Feb 10:43 onwards

Description:
Two related changes were made earlier today and a few minutes ago (see screenshot)

As a result of the earlier change fleet that I had "colo-saved" indefinitely suddenly appeared in High Orbit from all three of my race accounts.
For two accounts I had 10 of 10 Planets occupied and so colonising fleets were ejected due to "sufficient level of Colonization technology" (I presume) although there was no fleet movement or time expiry.
For my third account I had Planets 8 of 9 so I don't believe the fleets should have been ejected at all.
With the subsequent change, presumably implemented hurriedly due to unforseen consequences, I don't believe any of my fleets should have been ejected.
Clearly the changes were poorly designed (and/or tested) and they were not communicated in advance of implementation so players had time to prepare.
As a result, most of my fleets ejected to High Orbit were attacked and destroyed.
Please PM me for full details of accounts affected and fleet losses for recompense.

Actions required to repeat the problem:
Developers implement such a change again without sufficient design or testing and without notice so that players can't prepare for inevitable issues

Screenshot:
8 days ago
8 days ago
Post  Post #2 
Reputation 69
Group Terminator 31 12 20 Messages 2300
The bug of being in colonization without a real opportunity to colonize an object has been fixed.

After the players appealed, it was decided to leave the fleet (that is in colonization or has returned to colonization) in colonization, even if the level of Colonization Technology is insufficient.

However, if in the Galaxy panel there is no function to send to Colonization, and on the fleet dispatch page there is a choice of the “Colonization” order, then you need to create a topic in the section https://xcraft.ru/forum/forum_89, and not send EVERYTHING in this way.
This time "авось" it didn’t work out. Could be worse.
8 days ago
8 days ago

Information

You are not authorized

1 users are reading the topic (guests: 1)

Users: 0

Xcraft is a free browser strategy game with unique combat system.
Battle demonstration >>
Registration >>

2009 — 2524